3655 SquirrelMailで「アカウントが必要です。」が出る場

<<トップページへ

SquirrelMailで「アカウントが必要です。」が出る場
日時: 2008/10/27 18:04
名前: KT
SquirrelMailの最新版(squirrelmail-1.4.16-1.fc9.noarch)をyumで入れた場合、
pluginのsecure_loginを入れていると、
「このページにアクセスするにはアカウントが必要です。」
と表示され、メールが読めない状況になりました。
secure_loginを使わない設定にすれば解決しました。
サイトで紹介されているソースからのインストールの場合は違うかも知れませんし、
試してなくて恐縮ですが、もしこれで引っかかってる人がいたら注意してみてください。

(ここに書くことじゃないかも知れませんが、今僕がすごい引っかかってたので投稿します。
 ここにふさわしくない内容なら削除してください。)

Re: SquirrelMailで「アカウントが必要です。」が出る場(1)
日時: 2008/11/13 11:47
名前: ひまわり好き
初めまして。ひまわり好きです。
今、悪戦苦闘しながらも、こちらのサイトを参考にしながら、Fedora8のサーバ構築を行なせていただいています。非常に助かっています。ありがとうございます。

わたしも、SquirrelMailのsecure_loginというpluginでKTさんと同じような現象が起きております。わたしは、最新版secure_login-1.4-1.2.8.tar.gzをダウンロード、インストールしましたが、secure_loginを外すとログインできるのですが、使う設定にするとログインできない状態となります。

セキュリティ上、SSLは使いたいのですが、なにぶん初心者なので、解決方法がわかりません。
どなたか分かる方がいらっしゃいましたら、ご教授願います。

Re: SquirrelMailで「アカウントが必要です。」が出る場(2)
日時: 2008/11/15 00:23
名前: orange
私も同様の状態でした。
プラグインの使用はあきらめ、index.php
の内容を修正してしまいました。

header('Location: src/login.php');

header('Location: https://設置したディレクトリ/src/login.php');

Re: SquirrelMailで「アカウントが必要です。」が出る場(3)
日時: 2008/11/19 13:55
名前: ひまわり好き
>orangeさん

その方法だと、ベタでhttp://設置したディレクトリ/src/login.phpと打った時に、SSLにならないのでは?と思いますが、どうでしょうか?

Re: SquirrelMailで「アカウントが必要です。」が出る場(4)
日時: 2008/11/21 13:13
名前: orange
>ひまわり好きさん
こんにちは。

>・・ベタでhttp://設置したディレクトリ/src/login.phpと打った時に、SSLにならないのでは?
そうですね、おっしゃる通りです。

当方の場合、私を含め少数での利用が前提ですので、
http://設置したディレクトリ/”のみの入力で運用してます。
(実際は”htp://”の入力はしません)
多くのユーザでの利用が前提の場合、
ご指摘の通り不都合とかあるかもしれませんね。

Re: SquirrelMailで「アカウントが必要です。」が出る場(5)
日時: 2008/12/25 04:51
名前: かつ
>初めまして。ひまわり好きです。
>今、悪戦苦闘しながらも、こちらのサイトを参考にしながら、Fedora8のサーバ構築を行なせていただいています。非常に助かっています。ありがとうございます。
>
>わたしも、SquirrelMailのsecure_loginというpluginでKTさんと同じような現象が起きております。わたしは、最新版secure_login-1.4-1.2.8.tar.gzをダウンロード、インストールしましたが、secure_loginを外すとログインできるのですが、使う設定にするとログインできない状態となります。
>
>セキュリティ上、SSLは使いたいのですが、なにぶん初心者なので、解決方法がわかりません。
>どなたか分かる方がいらっしゃいましたら、ご教授願います。

はじめまして、

私も同様な現象が発生しました。

secure_loginのバージョンを落としたらログインできました。

参考になるかわかりませんが。。。

secure_login-1.4-1.2.8 → secure_login-1.3-1.2.8

Re: SquirrelMailで「アカウントが必要です。」が出る場(6)
日時: 2009/01/29 22:47
名前: 珀夜
当方の環境では、conf.pl メニューの

 General Options

を選択。

16. Only secure cookies if poss. : true

をFalseに変えたらうまくいきました。

Re: SquirrelMailで「アカウントが必要です。」が出る場(7)
日時: 2009/02/01 17:22
名前: ロースペック主義
初めまして。

横からすみませんが、

私も昨年から同様の症状に悩まされておりました。

私の環境では少々バージョンダウンしても変わらず。。

珀夜さんが書いているようにしたら、うまく動作しました!



こちらにもありましたね ↓

http://uglife.seesaa.net/article/113184807.html




Re: SquirrelMailで「アカウントが必要です。」が出る場(8)
日時: 2011/11/04 11:09
名前: anonymous
URL: http://squirrelmail.org/download.php
OSをアップデートしたあと、うちでも「アカウントが必要です。」と出ましたが、

http://squirrelmail.org/download.php から Development version snapshots (1.5.2-svn)

にアップデートすることでエラーが消えました。

Re: SquirrelMailで「アカウントが必要です。」が出る場(9)
日時: 2012/02/19 01:27
名前: mac
私もsecure_loginを使用していないのですが、
httpd.confにて
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_URI} ^/webmail
でhttpsにし、さらにssl.confにだけ
Alias /webmail /var/www/webmail
と記述しています。
secure_loginを使うメリットが良くわかりません。

※古いスレッドには返信できない場合があります


■関連コンテンツ




▲このページのトップへ戻る

Copyright© 2004-2017 fallenangels, All rights reserved.
ご自由にリンクしてください(連絡は不要です)
本ページへのご意見・ご要望、誤字・脱字・リンク切れ等のご連絡はこちらからお願いします